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ASPECT Rating Station 

 
The ASPECT Rating Station provides the main user environment for the collection and 
capture of assessment information. Specifically designed for the Tablet PC, the ASPECT 
Rating Station can be used unobtrusively during the actual interview process in lieu of 
paper forms, while also excelling for post-facto data entry and evaluation using desktop 
or laptop workstations in standalone, offline, or networked configurations. It consists of 
two main interface components: 
 

o Its clinical data visualization provides the clinician with the necessary tools to 
create or modify subject information and form data, showing at a glance the 
wealth of information stored within the data source and permitting the rapid 
location of each piece of data required. 

o The form data capture creates a highly intuitive interaction mechanism, as 
easy to use as a paper form but with embedded intelligence and functionality. 
Diverse capture methods permit the capture of different types of information, 
while alerts and expressions help the user for more effective assessment. 
Reports are generated for screen display or printing, and data is securely stored 
and signed by users through the interface. 

 
In reality, however, the ASPECT Rating Station has as many “looks” as it has forms 
configured, since each XML-based form definition specifies not only the data to be 
acquired, but also the way in which it will be presented on screen. Each form, in fact, 
can be configured to work in multiple languages, and with multiple layout configurations 
for different types of devices. In summary, the ASPECT Rating Station provides a wealth 
of tools and technologies designed to ease the assessment and data collection process. 
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Logging into the System 

When the ASPECT system starts up, it will require a user to login.  The user must enter a 
valid username and password to gain access the system. 
 

 
 
 

 

The username and password are assigned and changed at the ASPECT Control 
Center. 

 

 

Once the username and password are entered, the user can either click or tap 
on the OK button or hit the Enter key. 
 

 

 

Hitting the Cancel button exits the application. 

 
If the username or password is incorrect, the system displays an error message. 
 

 
 

 
Clicking the OK button allows the user to attempt to log in again. 
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Clinical Data Visualization 

When the ASPECT system starts up after the user logs in, the clinical data visualization 
screen is shown. This screen is designed to facilitate access to the different form data 
sets existing within the data source. 
 
The clinical data visualization screen is divided into three lists: 

o The leftmost list shows the identifiers for all the subjects existing in the system. 
These identifiers are composed of fields extracted from the Subject Information 
form, and may display the subject name, initials, patient ID, or any other 
information. 

o The center list contains all the form definitions existing in the system. Each 
form definition specifies a “blank” or “empty” form, and permits the selection of a 
new form to be filled out. 

o The rightmost list shows all the form data already collected, in essence, it shows 
all the “filled” forms. From this column, the user chooses forms that need to be 
modified. 

 

 

The identifiers to be displayed in the subject column are configured by the 
system administrator. 
 

 

 
ASPECT Rating Station Inter-Form Navigation 
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Buttons 

At the top part of each column, three buttons provide shortcuts to commonly used 
functionality. The working of each of these buttons is explained further below, in the 
section “Working with the Navigation Panel”. 
 

Menu Bar 

The menu bar on the main screen has one pull down menu entitled „File‟.  Under this 
menu, a more extensive set of selection and action options for the intra-form navigation 
panel can be found. These options are also explained below under “Working with the 
Navigation Panel”. 
 

 
ASPECT Rating Station Menu 

 

 

Buttons and menu options are enabled only when they are applicable. 
 

 

Status Bar 

The status bar at the bottom of the every window displays the name of the current user 
logged into the system, along with the time of login. 
 

 
User Name and Login Time 
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Selecting forms and subjects 

When neither subjects nor forms are selected, no form data instances are displayed. As 
soon as a subject is selected, all existing data instances of the selected subject are 
displayed in the right hand column. 
 

 
Subject Selected 

 
Similarly, when only a form is selected, all data instances of this form type are displayed 
in the data list. 
 

 
Form Selected 

 
When both a subject and a form are selected, only the data instances for a given 
subject and form are shown. 
 

 
Subject and Form Selected 
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Working with the Navigation Panel 

Working with Subjects 

If the user wishes to create a new subject, the „New Subject‟ button at the top of the 
subject column can be pressed.  The user can also select the „New Subject‟ item from 
the File menu. This will open up the Subject Information form and allow the user to enter 
and save information for the new subject.  Once the data is saved, the subject will 
appear on the screen in the subject list. 
 
To edit the information on an existing subject, a user can select the subject and click the 
“Open Subject” item on the File menu. Alternatively, a user can double-click the subject 
identifier in the navigation panel to open the existing subject‟s information form. 
 

 

The Subject Information form is just a special case of a form, and is defined and 
filled out in the same way as every other form. 
 

Filtering the List of Subjects 

The user can filter the list of subjects by typing text into the entry area above the 
Subjects column. The list will automatically be filtered to only include subjects that 

match the text. Click on the „clear‟ button ( ) to remove the filter and show all 
subjects. 
 

 
Filtering the list of Subjects 

Working with Forms 

To create a new set of form data for a subject, the user must first select a subject and 
form definition to use, then either: 

o click on the „New Form‟ button;  
o select the “New Form” menu item on the File menu; or 
o double-click on the form definition entry in the list. 

The system will open a blank version of the selected form definition, which the user can 
use to collect new form data for the subject. Once the data has been collected, it can be 
saved and will be represented in the form data column using the date. 



 Aspect Rating Station User’s Guide 

 © INFOTECH Soft, Inc.  11 

Working with Form Data 

The user may also wish to view, edit, or modify an existing set of form data.  To select a 
previously created set of form data the user must first select either a subject or form 
definition or a combination of both.  The form data column will display any form data 
sets associated with the current subject and/or form selections.  To select the data, the 
user can then highlight a set of form data and: 

o click the 'Open Form' button 
o select the “Open Form” menu item on the File menu; or 
o double-click on the form data entry on the list. 

 
The selected set of form data will be displayed using the form with which it was 
originally created.  It is noted that form data will always open using the version of the 
form definition that created it, which may not be the most recent version of the form 
definition. 
 
 



 Aspect Rating Station User’s Guide 

 © INFOTECH Soft, Inc.  12 

Data Entry 

Once either a new or existing form definition (or subject) has been selected, the Form 
Data Entry interface appears on screen, showing a form as its layout specifies, and if 
applicable, showing the existing data for the form. A form contains explanatory text for 
the user or clinician, and answer collection controls, which provide for user interaction to 
capture data. 

Entering Data 

There are five main types of answer collection controls: 
 

o Radio buttons are round buttons that (typically) allow only one selection out of 
a set of possibilities. The selected radio button is shown with a black dot within 
a circle, while unselected radio buttons are shown as open circles. To select a 
radio button, simply click on it with the mouse or tap it with the stylus. When 
using the keyboard, navigate with the up and down arrow keys to the desired 
selection and either tap the space bar or hit the enter key to select. 

 

 
A Set of Radio Buttons 

  
 

o Checkboxes allow multiple selections from a set of possibilities. Selected 
checkboxes are shown with a check mark inside a square box; unselected ones 
are empty boxes. Similar to a radio button, to select a checkbox, simply click on 
it with the mouse or tap it with the stylus. When using the keyboard, navigate 
with the up and down arrow keys to the desired selection and either tap the 
space bar or hit the enter key to select. 

 

 
A Set of Checkboxes 
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o Text boxes are boxes where text can be entered and/or displayed. To enter 
data into a text box, either type it with the keyboard or use the Tablet Input 
Panel and/or virtual keyboard to enter data. Input-type text boxes allow a single 
line of data, while text areas are a special type of text box that allows multiple 
lines of data, presenting if necessary a scroll bar to allow text to continue to 
grow. 

 
Different Types of Text Boxes 

 
o Drop down lists (sometimes called combo boxes) look like a text box with an 

arrow to the right side. When located on this control, clicking on or tapping the 
arrow displays a list from which a single selection can be made. Using the 
keyboard, hitting the Enter key displays the list; the up and down arrows permit 
the selection of one of the items in the list, which is then selected using either 
the space bar or the Enter key. 

 

 
A Drop Down List 

 



 Aspect Rating Station User’s Guide 

 © INFOTECH Soft, Inc.  14 

o Drawing panels allow the user to sketch a picture based on the question in the 
form, or to leave a handwritten note.  In either case, the drawing is done directly 
on the screen with the mouse or stylus at certain areas of the form.  All 
drawings are viewed as images, which can then be saved and will be 
redisplayed when the form is subsequently opened. 

 

 
Drawing Intersecting Pentagons 

 

Information Popups 

Popups provide the user with additional information relative to an item.  The user can 
click a corresponding button and the information, question, or other data space will be 
displayed in a window separate from the main form. 
 

 
An Informational Popup to Use with Drawing Areas 
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Tool Tips 

Tool Tips provide additional information to the user specific to an answer collection 
control.  By hovering the mouse over an answer, the tool tip will pop up. 
 

 

 
A Tool Tip is Displayed for the Answer Option 'Moderate' 
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Navigating within the Form 

In order to enter the collected information into the form, the user must be able to 
navigate from one control to another. Navigation also needs to occur to and from the 
buttons that represent the popups. To perform this navigation, three different 
mechanisms are available: keyboard navigation, navigation buttons, and a navigation 
tree. 

Keyboard Navigation 

To go from one control or popup button to another, the Tab and Shift-Tab keys are 
used. Tab proceeds forward in the direction of the form (usually, left-to-right, top-to-
bottom), while Shift-Tab proceeds in the reverse direction. The active control or popup 
can be easily distinguished by a conspicuous dotted border or by an editing cursor. 
 
The Page Up and Page Down keys permit more accelerated navigation, by displacing 
the active control marker roughly one screen down or up, respectively. 

Navigation Buttons 

The Previous and Next navigation buttons provide the user with the same functionality 
as the Shift-Tab and Tab keys, respectively, and are better suited for use with a mouse 
or stylus. The navigation buttons are located on the tool bar of the form, and also on the 
Edit menu. 
 

 
Previous and Next Navigation Buttons 
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Navigation Tree 

The Navigation Tree shows the complete form layout within a tree view.  The user can 
switch to the Navigation view of the form by selecting the "Tree" button on the toolbar, 
or by using the “Show Navigation Tree” menu item on the “View” menu. Item groups 
within the tree can be expanded to view the items and subgroups within the group.  By 
selecting and item or group, the focus of the form will jump to the selected area.  The 
Navigation Tree can also be hidden by again choosing "Tree" from the toolbar or by 
using the “Hide Navigation Tree” menu item on the “View” menu. 
 

 
Navigation Tree View 

 

The Navigation Tree can be expanded by clicking ( ) or collapsed by clicking ( ). 
 

 
Navigation Tree Expanded 

 
Navigation Tree Collapsed 
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Read-only Data 

In some cases, users will have permission to read and review a piece of data, but not 
be able to modify the data.  When viewing read-only data, the user can only traverse 
between items in the form by using the navigation tree or the scrollbar. 

Running Headers 

A running header is an information bar that updates the user as to their current 
position within the form.   As a user traverses the form, the running header will display 
the name of the form section where the cursor is focused.  The running header 
provides a quick reference for the user as to the section of the form for which the item 
they are working with is located.  The running header is situated between the toolbar 
and the form. 

 
Running Header 

Highlighted Items 

Highlighted items alert the user as to the current focus of the cursor within a form.  
These items appear with a background color that is different to the color of the other 
items within the form. The highlighted item should be the item with which the user is 
presently working. 

 

 
Highlighted Item in Light Blue 
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Multi-Valued Tables 

Entering data on Multi-Valued Tables 

Tables can be constructed to collect multiple sets of data with the same general 
structure.  When a table is empty, a single row of empty data is shown on screen; when 
new data is entered into any field within this empty row, the table automatically 
expands, always showing an empty row at the end of the table. 
 

 

Not all tables are multi-valued. Some tables are simply a group of answer 
control mechanisms aligned in a tabular manner. These non-multi-valued tables 
do not grow, and do not have delete buttons. 

 

 
The Multi-Valued Table Always Shows an Empty Row 

 

 
The Multi-Valued Table Adds New Rows Automatically 

Navigating within a Multi-Valued Table 

Each cell within a table contains an answer collection control. To navigate among these, 
the usual navigation methods (keyboard, buttons) are used. When navigation reaches 
the last cell of the empty last row of the table, selection proceeds to the next item within 
the form. 
 

 
Unlike other interfaces, using the Tab key at the last cell on the last row does 
not insert a new empty row. Insertion of an empty row is achieved by entering 
data in any field within the last row of the table. 
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Deleting Table Rows 

All table rows have a delete button at the right side of the row; all but the last button are 
enabled. Clicking on this delete button displays a confirmation message; accepting the 
message by selecting OK removes the entire row from the table. 
 

 
Removing a Row from a Multi-Valued Table 

Inserting and Removing Annotations 

An annotation allows the user to enter additional information relative to the item.  
Included can be comments, descriptions, or other data the user may desire to provide. 
Annotations are inserted by clicking on the Add Note button on the toolbar, or by 
selecting the Add Note menu item on the Edit menu; insertion of an annotation is done 
at the item whose answer collection control is selected.  
 
Annotations can only be inserted if the design of the form allows it; otherwise, the Add 
Note toolbar and menu item are disabled. Multiple annotations can be inserted at the 
same item; each annotation is displayed with a user ID and a creation date. 
 
To remove an inserted annotation, the annotation itself must be currently selected (by 
having the text cursor, i.e., an I-shaped cursor, showing on the annotation body). When 
the Remove Note toolbar button, or the Remove Note menu item in the Edit menu, is 
selected, a dialog requesting confirmation appears; if the user confirms, the note is 
deleted from the form. 

 
Adding an Annotation to the Item 
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Marked Items 

Marked items allow a user to highlight an item to be reviewed. Marked items appear 

highlighted within the form and a marked ( ) icon appears in the Navigation Tree. 
Items can be marked or unmarked by selecting the item either in the Navigation Tree or 
within the form and typing CTRL+M or by selecting “Toggle Mark” from the Edit menu. 

The Navigation Tree also includes a button ( ) to filter the tree by marked items. 
Clicking on the filter button toggles the tree view between showing only marked items or 
all items. 

 
Marked Items Highlighted in Blue 

Undo/Redo 

The ASPECT system allows the user to cycle backwards or forwards though the 
changes made to a form by using the Undo and Redo buttons, or the “Undo” and 
“Redo” menu items in the “Edit” menu.  By selecting Undo, the most recently changed 
data will revert to its pre-changed value.  The user may continue to select the Undo 
button and the old data will be restored, one change at a time.  If the user decides to 
reestablish the changes made to the data, the Redo button can replace the data 
change made by using the most recent Undo action.  Continuing to select the Redo 
button allows the user to cycle forward though each of the Undo actions selected, 
progressively replacing the data. 

Most actions are undoable, including the entry or selection of data, and the insertion or 
removal of annotations and table rows. 

In most answer collection controls, including single line input text boxes, the undo and 
redo actions switch between values set after the control loses its selection. In text 
areas, however, undo and redo work at the character insertion level. 
 

 

Undo and Redo have an accelerator key, that is, a key stroke that has the same 
functionality as the toolbar button. For Undo it is Ctrl-Z, for Redo it is Ctrl-Y. 
 

 
The Undo and Redo Buttons 



 Aspect Rating Station User’s Guide 

 © INFOTECH Soft, Inc.  22 

Automatic Calculations 

An output expression is an automatically calculated result, based on data within the 
form or from other forms within the system.  Output expression examples are a total 
score based on the sum of a users answers, a calculation of an age or range of years 
based on provided dates, or a determination of truth or falsehood for a determined 
condition. These output expressions are usually displayed within the form on output 
boxes, which are similar to input text boxes, except that they do not allow entry of data, 
and are shown in a different, system-specific coloring (gray on Windows systems). 
 
A calculated field is updated automatically whenever data that affects its result is 
changed. 
 

 
Output Expression Calculates the Sum of Selected Values 

 

Conditional Processing 

The ASPECT Rating Station has a comprehensive system for processing of conditions 
within the form. These conditions are generally dependent on the data within the form 
itself, and could also depend on data within other forms. They can be triggered by one 
or more of the following events: 

o Upon form opening 
o Upon selection (focus) reaching an answer collection control 
o Upon selection (focus) leaving an answer collection control 
o Upon a change in value in the answer collection control. 

 

 

The event that triggers processing of a condition, as well as the nature of the 
condition itself, are determined by the design of the form. 
 

 
There are three types of conditional processing results: alerts, enabling / disabling of 
items, and logic flow. 

Alerts 

An alert is an informative message displayed to the user, triggered by a condition. Alerts 
are used to warn the user or clinician about potentially ambiguous or contradictory 
responses, or in general to provide help and guidance. 
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Customized Alert Message 

Item Enabling/Disabling 

Individual questions or entire sections within a form may be automatically enabled for 
answering or disabled to prevent answering by the user.  Among reasons of disabling 
questions are if the questions are gender specific, if they are age or time related, or are 
otherwise determined to be disregarded or unnecessary based on the user's answers to 
other questions.  Enabling questions may occur if the age or gender is applicable, if the 
questions are determined to be relevant based on previous answers, or if answer(s) 
causing a question to become disabled have been changed, therefore re-enabling the 
question. 
 

 
Disabling the Textbox 

Logic Flow 

Logic flow is used to guide the user through the form based on the form's logic 
structure.  As the user answers questions, any associated logic conditions are 
calculated.  As conditions are met, a message is displayed notifying the user of the 
condition and the next question or section to complete.  If the user accepts, the form will 
automatically jump to the next question for the user to answer. 
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Logic Flow Alert Displayed Based on Selected Answers 
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Language Selection 

A form may be defined in multiple languages. If more than one language is available, 
the “Set Language” menu item within the View menu presents the user with all possible 
choices. 

 
Language selection menu 

 
Upon selection, the form is immediately presented in the selected language. 
 

 
Hamilton Scale in Spanish 

 

 

The configuration of a form in multiple languages is done at the ASPECT Control 
Center. 
 

 

 

When languages are switched, entered answers remain in the form. Any text 
entered in a form is not translated, however. 
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Reports 

The ASPECT system can automatically create a report for a set of form data.  The user 
must have a chosen form and data set open to view the corresponding report.  The user 
can select to create and view a report by choosing the 'View Report' option under the 
'View' area of the form menu. 
 

 
Report View for a Set of Form Data 
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Saving Form Data 

Once the user has completed editing the form, the data may be saved as modified data 
or as new data.  To save as modified data, the user selects „Save Data‟ from the menu 
bar or toolbar. This will override the old data with the updated data, but retain the same 
form date used in the selection list.  To save as new data, the user selects „Save Copy 
of Data‟ from the menu bar.  This will create a new set of form data.  A new date (the 
current date) will be used to represent the form data in the selection list.  
 
After a form is saved, the “Save Data” button and menu item are disabled. They 
become re-enabled when any data is modified within the form. 
 

 
Saving Form Data 
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Signing Form Data 

Each set of form data can be signed by a user with an appropriate permission level.  By 
signing the form data, the user validates the authenticity of the collected information.  In 
order to sign the data, the user selects the 'Sign Data' option from the File menu on the 
form. If the data currently on screen has not been saved yet, the user is prompted to 
confirm saving the data before signing. If the user does not elect to save, then the data 
is not signed. 
 

 
Prompt to Save Data before Signing 

 
If the data on screen was already saved, or if the user selects to save before signing, 
then the system requests the user to reconfirm her or his password, to ensure maximum 
security for the signature.  
 

 
Request for Password to Sign Data 
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If the password is incorrect, the user is informed and the form is not signed; otherwise, 
the form is signed and the user may continue editing it or may exit the form data 
capture. 
 

 
Password Entry Failed 

 

Often, users may wish to sign an instance of data to validate its authenticity and 
accuracy.  Once form data has been signed, an icon appears next to the data on the 
Rating Station screen.  Only users with permission to view the signed data will be able 
to see this icon and open the data. 

 

 
Signed Data with Icon 

 

Once signed data has been opened, an entry list is displayed at the bottom of the form 
to indicate when the data was signed, and by which user. 

 

 
Signature List with Users and Dates 

 

The signatures can be shown or hidden by selecting the Show Signatures option from 
the View menu. 
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Show Signatures Menu Option 

 

Closing Form Data 

To close a form data, the user selects the Close menu item in the File menu, or the 
close button on the top right corner of the window. If the current data has not been 
saved, the system asks the user if he or she wants to save the form, return to the form, 
or close without saving. By default, the “Return to form” option is selected; the user can 
click or tap on any of the other buttons, or navigate among them using the Tab key. 
 

 
Request to save data before closing a form 
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If “Save and Close” is selected, the data is saved and the form is closed. If “Return to 
form” is selected, then no data is saved but the form continues to show on screen. If 
“Close without saving” is selected, the form presents an additional confirmation dialog, 
warning the user that data may be lost. 
 

 
Confirmation dialog to close a form without saving 

 
If the user selects the “Yes” option, data is not saved and the form is closed. If the “No” 
option is selected, the form is not closed, and data is not saved. 


